Nachdem ich gerade beim Setup (Move standalone auf clustered) in alle Fallen gelaufen bin die sich dabei bieten hier eine kleine Aufstellung der notwendingen Schritte:

  • Prerequisite: Cluster (nix shared), nanonaned – und das is der einfache Teil 😀
  • Prerequisite: Windows ADK 8.1 (Deployment Tools & PE)
  • Prerequisite: SQL 2012 Native Client (aus Feature Pack)
  • Prerequisite: SQL 2012 Command Line Tools (aus Feature Pack)
  • Dann wollte er natürlich einen Reboot 😐
  • Dann bin ich gleich mal auf der DB Seite im Setup Wizard eingefahren (cannot verify account oder so) – der Service Account den man angibt muss auf allen (dritter Start :-D) Clusternodes Admin sein.
  • Den vierten Versuch hab ich gebraucht für die Erkenntnis dass fürs Setup die DB noch nicht in einer AlwaysOn Availability Group sein darf – als Fehler kommt irgendwas mit kann nicht auf DB zugreifen, im Log (C:\ProgramData\VMMLogs\SetupWizard.log) steht dann die InnerException mit der tatsächlichen Ursache.
  • Der fünfte Versuch ging dafür drauf dass der Service Account zumindestens die SQL Server Rollen „dbcreator“, „processadmin“ und „securityadmin“ benötigt (db_owner auf DB ist eh klar) – als Fehler kommt hier irgendwas mit man solle doch MSSQL$ starten (das Service)….wiederum hilft das VMMLog weiter.
  • Dann sind die Setups zumindestens durchgelaufen, da der SPN von der alten Installation noch vorhanden war ist er beim Erzeugen gleich mal drüber gestolpert und hat mich mit Infos was ich denn alles jetzt manuell machen muss (setspn -S und C:\Program Files\Microsoft System Center 2012 R2\Virtual Machine Manager\setup\ConfigureSCPTool.exe -install) eingedeckt.
  • Clusterresource startet trotzdem nicht – im EventLog (System) findet sich der obligatorische Eintrag dass das Clusterkonto das Rechnerkonto mangels Rechten nicht erzeugen kann – also „leer“ angelegt und Clusterkonto berechtigt und siehe da – ES TUT 😀